freeswitch-sounds-en-us-callie.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363
  1. ##############################################################################
  2. # Copyright and license
  3. ##############################################################################
  4. #
  5. # Spec file for package freeswitch-sounds-en-us-callie (version 1.0.52-1)
  6. #
  7. # Copyright (c) 2009 Patrick Laimbock
  8. # Some fixes and additions (c) 2011 Michal Bielicki
  9. # This file and all modifications and additions to the pristine
  10. # package are under the same license as the package itself.
  11. #
  12. ##############################################################################
  13. # Determine distribution
  14. ##############################################################################
  15. # %define is_rhel5 %(test -f /etc/redhat-release && egrep -q 'release 5' /etc/redhat-release && echo 1 || echo 0)
  16. ##############################################################################
  17. # Set variables
  18. ##############################################################################
  19. %define version 1.0.52
  20. %define release 1
  21. %define fsname freeswitch
  22. # you could add a version number to be more strict
  23. %define PREFIX %{_prefix}
  24. %define EXECPREFIX %{_exec_prefix}
  25. %define BINDIR %{_bindir}
  26. %define SBINDIR %{_sbindir}
  27. %define LIBEXECDIR %{_libexecdir}/%{fsname}
  28. %define SYSCONFDIR %{_sysconfdir}/%{fsname}
  29. %define SHARESTATEDIR %{_sharedstatedir}/%{fsname}
  30. %define LOCALSTATEDIR %{_localstatedir}/lib/%{fsname}
  31. %define LIBDIR %{_libdir}
  32. %define INCLUDEDIR %{_includedir}
  33. %define _datarootdir %{_prefix}/share
  34. %define DATAROOTDIR %{_datarootdir}
  35. %define DATADIR %{_datadir}
  36. %define INFODIR %{_infodir}
  37. %define LOCALEDIR %{_datarootdir}/locale
  38. %define MANDIR %{_mandir}
  39. %define DOCDIR %{_defaultdocdir}/%{fsname}
  40. %define HTMLDIR %{_defaultdocdir}/%{fsname}/html
  41. %define DVIDIR %{_defaultdocdir}/%{fsname}/dvi
  42. %define PDFDIR %{_defaultdocdir}/%{fsname}/pdf
  43. %define PSDIR %{_defaultdocdir}/%{fsname}/ps
  44. %define LOGFILEDIR /var/log/%{fsname}
  45. %define MODINSTDIR %{_libdir}/%{fsname}/mod
  46. %define RUNDIR %{_localstatedir}/run/%{fsname}
  47. %define DBDIR %{LOCALSTATEDIR}/db
  48. %define HTDOCSDIR %{_datarootdir}/%{fsname}/htdocs
  49. %define SOUNDSDIR %{_datarootdir}/%{fsname}/sounds
  50. %define GRAMMARDIR %{_datarootdir}/%{fsname}/grammar
  51. %define SCRIPTDIR %{_datarootdir}/%{fsname}/scripts
  52. %define RECORDINGSDIR %{LOCALSTATEDIR}/recordings
  53. %define PKGCONFIGDIR %{_datarootdir}/%{fsname}/pkgconfig
  54. %define HOMEDIR %{LOCALSTATEDIR}
  55. ##############################################################################
  56. # General
  57. ##############################################################################
  58. Summary: FreeSWITCH en-us Callie prompts
  59. Name: freeswitch-sounds-en-us-callie
  60. Version: %{version}
  61. Release: %{release}%{?dist}
  62. License: MPL
  63. Group: Applications/Communications
  64. Packager: Patrick Laimbock <vc-rpms@voipconsulting.nl>
  65. URL: http://www.freeswitch.org
  66. Source0:http://files.freeswitch.org/releases/sounds/%{name}-48000-%{version}.tar.gz
  67. Source1:http://files.freeswitch.org/releases/sounds/%{name}-32000-%{version}.tar.gz
  68. Source2:http://files.freeswitch.org/releases/sounds/%{name}-16000-%{version}.tar.gz
  69. Source3:http://files.freeswitch.org/releases/sounds/%{name}-8000-%{version}.tar.gz
  70. BuildArch: noarch
  71. BuildRequires: sox
  72. Requires: freeswitch
  73. Requires: freeswitch-sounds-en-us-callie-48000
  74. Requires: sox
  75. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  76. %description
  77. FreeSWITCH 48kHz en-us Callie prompts plus, during the installation,
  78. it will also install locally generated 8KHz, 16KHz and 32KHz prompts
  79. %package -n freeswitch-sounds-en-us-callie-8000
  80. Summary: FreeSWITCH 8kHz en-us Callie prompts
  81. Group: Applications/Communications
  82. BuildArch: noarch
  83. Requires: %{fsname}
  84. %description -n freeswitch-sounds-en-us-callie-8000
  85. FreeSWITCH 8kHz en-us Callie prompts
  86. %package -n freeswitch-sounds-en-us-callie-16000
  87. Summary: FreeSWITCH 16kHz en-us Callie prompts
  88. Group: Applications/Communications
  89. BuildArch: noarch
  90. Requires: %{fsname}
  91. %description -n freeswitch-sounds-en-us-callie-16000
  92. FreeSWITCH 16kHz en-us Callie prompts
  93. %package -n freeswitch-sounds-en-us-callie-32000
  94. Summary: FreeSWITCH 32kHz en-us Callie prompts
  95. Group: Applications/Communications
  96. BuildArch: noarch
  97. Requires: %{fsname}
  98. %description -n freeswitch-sounds-en-us-callie-32000
  99. FreeSWITCH 32kHz en-us Callie prompts
  100. %package -n freeswitch-sounds-en-us-callie-48000
  101. Summary: FreeSWITCH 48kHz en-us Callie prompts
  102. Group: Applications/Communications
  103. BuildArch: noarch
  104. Requires: %{fsname}
  105. %description -n freeswitch-sounds-en-us-callie-48000
  106. FreeSWITCH 48kHz en-us Callie prompts
  107. %package -n freeswitch-sounds-en-us-callie-all
  108. Summary: FreeSWITCH en-us Callie prompts
  109. Group: Applications/Communications
  110. BuildArch: noarch
  111. Requires: %{fsname}
  112. Requires: freeswitch-sounds-en-us-callie-8000 = %{version}
  113. Requires: freeswitch-sounds-en-us-callie-16000 = %{version}
  114. Requires: freeswitch-sounds-en-us-callie-32000 = %{version}
  115. Requires: freeswitch-sounds-en-us-callie-48000 = %{version}
  116. %description -n freeswitch-sounds-en-us-callie-all
  117. FreeSWITCH Callie prompts package that pulls in the 8KHz, 16KHz,
  118. 32KHz and 48KHz RPMs
  119. ##############################################################################
  120. # Prep
  121. ##############################################################################
  122. %prep
  123. %setup -n en
  124. %setup -T -D -b 0 -n en
  125. %setup -T -D -b 1 -n en
  126. %setup -T -D -b 2 -n en
  127. %setup -T -D -b 3 -n en
  128. ##############################################################################
  129. # Build
  130. ##############################################################################
  131. %build
  132. # nothing to do here
  133. ##############################################################################
  134. # Install
  135. ##############################################################################
  136. %install
  137. [ "%{buildroot}" != '/' ] && rm -rf %{buildroot}
  138. # create the sounds directories
  139. %{__install} -d -m 0750 %{buildroot}%{SOUNDSDIR}/en/us/callie
  140. pushd us/callie
  141. # first install the 48KHz sounds
  142. %{__cp} -prv ./* %{buildroot}%{SOUNDSDIR}/en/us/callie
  143. # now resample the 48KHz ones to 8KHz, 16KHz and 32KHz
  144. popd
  145. ##############################################################################
  146. # Clean
  147. ##############################################################################
  148. %clean
  149. [ "%{buildroot}" != '/' ] && rm -rf %{buildroot}
  150. ##############################################################################
  151. # Post
  152. ##############################################################################
  153. %post
  154. # generate the 8KHz, 16KHz and 32KHz prompts from the 48KHz ones
  155. ##############################################################################
  156. # Postun
  157. ##############################################################################
  158. %postun
  159. # you could check if there are sound files in 8000/ or
  160. # 16000/ or 32000/ and remove them *only* if the files
  161. # do not belong to an rpm
  162. ##############################################################################
  163. # Files
  164. ##############################################################################
  165. %files
  166. %defattr(-,root,root)
  167. %files -n freeswitch-sounds-en-us-callie-8000
  168. %defattr(-,root,root,-)
  169. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/ascii/8000
  170. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/base256/8000
  171. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/conference/8000
  172. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/currency/8000
  173. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/digits/8000
  174. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/directory/8000
  175. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/ivr/8000
  176. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/misc/8000
  177. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/phonetic-ascii/8000
  178. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/time/8000
  179. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/voicemail/8000
  180. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/zrtp/8000
  181. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/ascii/8000/*.wav
  182. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/base256/8000/*.wav
  183. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/conference/8000/*.wav
  184. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/currency/8000/*.wav
  185. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/digits/8000/*.wav
  186. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/directory/8000/*.wav
  187. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/ivr/8000/*.wav
  188. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/misc/8000/*.wav
  189. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/phonetic-ascii/8000/*.wav
  190. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/time/8000/*.wav
  191. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/voicemail/8000/*.wav
  192. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/zrtp/8000/*.wav
  193. %files -n freeswitch-sounds-en-us-callie-16000
  194. %defattr(-,root,root,-)
  195. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/ascii/16000
  196. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/base256/16000
  197. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/conference/16000
  198. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/currency/16000
  199. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/digits/16000
  200. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/directory/16000
  201. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/ivr/16000
  202. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/misc/16000
  203. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/phonetic-ascii/16000
  204. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/time/16000
  205. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/voicemail/16000
  206. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/zrtp/16000
  207. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/ascii/16000/*.wav
  208. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/base256/16000/*.wav
  209. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/conference/16000/*.wav
  210. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/currency/16000/*.wav
  211. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/digits/16000/*.wav
  212. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/directory/16000/*.wav
  213. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/ivr/16000/*.wav
  214. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/misc/16000/*.wav
  215. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/phonetic-ascii/16000/*.wav
  216. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/time/16000/*.wav
  217. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/voicemail/16000/*.wav
  218. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/zrtp/16000/*.wav
  219. %files -n freeswitch-sounds-en-us-callie-32000
  220. %defattr(-,root,root,-)
  221. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/ascii/32000
  222. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/base256/32000
  223. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/conference/32000
  224. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/currency/32000
  225. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/digits/32000
  226. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/directory/32000
  227. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/ivr/32000
  228. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/misc/32000
  229. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/phonetic-ascii/32000
  230. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/time/32000
  231. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/voicemail/32000
  232. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/zrtp/32000
  233. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/ascii/32000/*.wav
  234. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/base256/32000/*.wav
  235. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/conference/32000/*.wav
  236. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/currency/32000/*.wav
  237. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/digits/32000/*.wav
  238. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/directory/32000/*.wav
  239. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/ivr/32000/*.wav
  240. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/misc/32000/*.wav
  241. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/phonetic-ascii/32000/*.wav
  242. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/time/32000/*.wav
  243. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/voicemail/32000/*.wav
  244. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/zrtp/32000/*.wav
  245. %files -n freeswitch-sounds-en-us-callie-48000
  246. %defattr(-,root,root,-)
  247. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/ascii/48000
  248. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/base256/48000
  249. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/conference/48000
  250. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/currency/48000
  251. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/digits/48000
  252. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/directory/48000
  253. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/ivr/48000
  254. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/misc/48000
  255. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/phonetic-ascii/48000
  256. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/time/48000
  257. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/voicemail/48000
  258. %attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/en/us/callie/zrtp/48000
  259. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/ascii/48000/*.wav
  260. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/base256/48000/*.wav
  261. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/conference/48000/*.wav
  262. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/currency/48000/*.wav
  263. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/digits/48000/*.wav
  264. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/directory/48000/*.wav
  265. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/ivr/48000/*.wav
  266. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/misc/48000/*.wav
  267. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/phonetic-ascii/48000/*.wav
  268. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/time/48000/*.wav
  269. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/voicemail/48000/*.wav
  270. %attr(0640,freeswitch,daemon) %{SOUNDSDIR}/en/us/callie/zrtp/48000/*.wav
  271. %files -n freeswitch-sounds-en-us-callie-all
  272. ##############################################################################
  273. # Changelog
  274. ##############################################################################
  275. %changelog
  276. * Fri Apr 19 2019 Andrey Volk <andrey@signalwire.com> - 1.0.52-1
  277. - bump up version
  278. * Sun Mar 05 2012 Ken Rice <krice@freeswitch.org> - 1.0.18-1
  279. - update to FHS Layout for FreeSWITCH
  280. - bump up version
  281. * Sun May 22 2011 Michal Bielicki <michal.bielicki@seventhsignal.de> - 1.0.16-1
  282. - bump up version
  283. * Tue Jan 18 2011 Michal Bielicki <michal.bielicki@seventhsignal.de> - 1.0.14-1
  284. - bump up version
  285. - include script into freeswitch core
  286. - include specfile into freeswitch core
  287. - runtime does not require sox, only building
  288. * Thu Dec 17 2009 Patrick Laimbock <vc-rpms@voipconsulting.nl> - 1.0.12-8
  289. - update perms and user/group to sync with the old situation
  290. * Wed Dec 16 2009 Patrick Laimbock <vc-rpms@voipconsulting.nl> - 1.0.12-7
  291. - make main package require freeswitch-sounds-en-us-callie-48000 and
  292. - generate the 8KHz, 16KHz and 32KHz sounds from there
  293. - add license to spec file
  294. * Wed Dec 16 2009 Patrick Laimbock <vc-rpms@voipconsulting.nl> - 1.0.12-5
  295. - put 48KHz in a separate package and let the main package Require 48KHz
  296. - and then use the script to generate the 8KHz, 16KHz and 32KHz sounds
  297. * Wed Dec 16 2009 Patrick Laimbock <vc-rpms@voipconsulting.nl> - 1.0.12-4
  298. - add freeswitch-sounds-en-us-callie-all package that pulls in the 8KHz,
  299. - 16KHz, 32KHz and 48KHz RPM packages
  300. * Tue Dec 15 2009 Patrick Laimbock <vc-rpms@voipconsulting.nl> - 1.0.12-3
  301. - override subpackage name with -n so it no longer builds an empty main RPM
  302. - rework spec file
  303. - add sox as a requirement
  304. - run buildsounds-callie.sh in post to generate 8KHz, 16KHz and 32KHz prompts
  305. * Tue Dec 15 2009 Patrick Laimbock <vc-rpms@voipconsulting.nl> - 1.0.12-2
  306. - can't override Name in subpackage so put all versions in RPM subpackages
  307. - with an empty main RPM package
  308. * Tue Dec 15 2009 Patrick Laimbock <vc-rpms@voipconsulting.nl> - 1.0.12-1
  309. - create spec file with the following requirement:
  310. - source only contains the 48KHz sound prompts
  311. - during build the 48KHz sound prompts are resampled to 8KHz, 16KHz and 32KHz
  312. - the 8KHz, 16KHz, 32KHz and 48KHz sound prompts are packaged separately