freeswitch-config-rayo.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175
  1. ######################################################################################################################
  2. #
  3. # freeswitch-config-rayo for FreeSWITCH Modular Media Switching Software Library / Soft-Switch Application
  4. # Copyright (C) 2013-2015, Grasshopper
  5. #
  6. # Version: MPL 1.1
  7. #
  8. # The contents of this file are subject to the Mozilla Public License Version
  9. # 1.1 (the "License"); you may not use this file except in compliance with
  10. # the License. You may obtain a copy of the License at
  11. # http://www.mozilla.org/MPL/
  12. #
  13. # Software distributed under the License is distributed on an "AS IS" basis,
  14. # WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
  15. # for the specific language governing rights and limitations under the
  16. # License.
  17. #
  18. # The Original Code is freeswitch-config-rayo for FreeSWITCH Modular Media Switching Software Library / Soft-Switch Application
  19. #
  20. # The Initial Developer of the Original Code is Grasshopper
  21. # Portions created by the Initial Developer are Copyright (C)
  22. # the Initial Developer. All Rights Reserved.
  23. #
  24. # Contributor(s):
  25. # Chris Rienzo <crienzo@grasshopper.com>
  26. #
  27. # freeswitch-rayo-config -- RPM packaging for Rayo Server configuration
  28. #
  29. ######################################################################################################################
  30. %define version 1.5.16
  31. %define release 1
  32. %define fsname freeswitch
  33. %define PREFIX %{_prefix}
  34. %define EXECPREFIX %{_exec_prefix}
  35. %define BINDIR %{_bindir}
  36. %define SBINDIR %{_sbindir}
  37. %define LIBEXECDIR %{_libexecdir}/%fsname
  38. %define SYSCONFDIR %{_sysconfdir}/%fsname
  39. %define SHARESTATEDIR %{_sharedstatedir}/%fsname
  40. %define LOCALSTATEDIR %{_localstatedir}/lib/%fsname
  41. %define LIBDIR %{_libdir}
  42. %define INCLUDEDIR %{_includedir}
  43. %define _datarootdir %{_prefix}/share
  44. %define DATAROOTDIR %{_datarootdir}
  45. %define DATADIR %{_datadir}
  46. %define INFODIR %{_infodir}
  47. %define LOCALEDIR %{_datarootdir}/locale
  48. %define MANDIR %{_mandir}
  49. %define DOCDIR %{_defaultdocdir}/%fsname
  50. %define HTMLDIR %{_defaultdocdir}/%fsname/html
  51. %define DVIDIR %{_defaultdocdir}/%fsname/dvi
  52. %define PDFDIR %{_defaultdocdir}/%fsname/pdf
  53. %define PSDIR %{_defaultdocdir}/%fsname/ps
  54. %define LOGFILEDIR /var/log/%fsname
  55. %define MODINSTDIR %{_libdir}/%fsname/mod
  56. %define RUNDIR %{_localstatedir}/run/%fsname
  57. %define DBDIR %{LOCALSTATEDIR}/db
  58. %define HTDOCSDIR %{_datarootdir}/%fsname/htdocs
  59. %define SOUNDSDIR %{_datarootdir}/%fsname/sounds
  60. %define GRAMMARDIR %{_datarootdir}/%fsname/grammar
  61. %define SCRIPTDIR %{_datarootdir}/%fsname/scripts
  62. %define RECORDINGSDIR %{LOCALSTATEDIR}/recordings
  63. %define PKGCONFIGDIR %{_datarootdir}/%fsname/pkgconfig
  64. %define HOMEDIR %{LOCALSTATEDIR}
  65. Name: freeswitch-config-rayo
  66. Version: %{version}
  67. Release: %{release}%{?dist}
  68. License: MPL1.1
  69. Summary: Rayo configuration for the FreeSWITCH Open Source telephone platform.
  70. Group: System/Libraries
  71. Packager: Chris Rienzo
  72. URL: http://www.freeswitch.org/
  73. Source0: freeswitch-%{version}.tar.bz2
  74. Requires: freeswitch
  75. Requires: freeswitch-application-conference
  76. Requires: freeswitch-application-esf
  77. Requires: freeswitch-application-expr
  78. Requires: freeswitch-application-fsv
  79. Requires: freeswitch-application-http-cache
  80. Requires: freeswitch-asrtts-flite
  81. Requires: freeswitch-asrtts-pocketsphinx
  82. Requires: freeswitch-codec-celt
  83. Requires: freeswitch-codec-h26x
  84. Requires: freeswitch-codec-ilbc
  85. Requires: freeswitch-codec-opus
  86. Requires: freeswitch-codec-vp8
  87. Requires: freeswitch-event-rayo
  88. Requires: freeswitch-format-local-stream
  89. Requires: freeswitch-format-mod-shout
  90. Requires: freeswitch-format-shell-stream
  91. Requires: freeswitch-format-ssml
  92. Requires: freeswitch-sounds-music-8000
  93. Requires: freeswitch-lang-en
  94. Requires: freeswitch-sounds-en-us-callie-8000
  95. BuildRequires: bash
  96. BuildArch: noarch
  97. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  98. %description
  99. FreeSWITCH rayo server implementation.
  100. %prep
  101. %setup -b0 -q -n freeswitch-%{version}
  102. %build
  103. %install
  104. %{__rm} -rf %{buildroot}
  105. %{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}
  106. %{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}/autoload_configs
  107. %{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}/dialplan
  108. %{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}/sip_profiles
  109. %{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}/directory
  110. %{__cp} -prv ./conf/rayo/*.{xml,types,pem} %{buildroot}/%{SYSCONFDIR}/
  111. %{__cp} -prv ./conf/rayo/{autoload_configs,dialplan} %{buildroot}/%{SYSCONFDIR}/
  112. %{__cp} -prv ./conf/rayo/sip_profiles/external.xml %{buildroot}/%{SYSCONFDIR}/sip_profiles
  113. %{__cp} -prv ./conf/rayo/sip_profiles/external %{buildroot}/%{SYSCONFDIR}/sip_profiles
  114. %{__cp} -prv ./conf/rayo/directory %{buildroot}/%{SYSCONFDIR}/
  115. %postun
  116. %clean
  117. %{__rm} -rf %{buildroot}
  118. %files
  119. %defattr(-,freeswitch,daemon)
  120. %dir %attr(0750, freeswitch, daemon) %{SYSCONFDIR}
  121. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/cacert.pem
  122. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/*.xml
  123. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/mime.types
  124. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/acl.conf.xml
  125. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/cdr_csv.conf.xml
  126. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/conference.conf.xml
  127. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/console.conf.xml
  128. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/event_socket.conf.xml
  129. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/http_cache.conf.xml
  130. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/local_stream.conf.xml
  131. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/logfile.conf.xml
  132. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/modules.conf.xml
  133. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/pocketsphinx.conf.xml
  134. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/post_load_modules.conf.xml
  135. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/presence_map.conf.xml
  136. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/rayo.conf.xml
  137. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/shout.conf.xml
  138. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/sofia.conf.xml
  139. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/spandsp.conf.xml
  140. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/ssml.conf.xml
  141. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/switch.conf.xml
  142. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/timezones.conf.xml
  143. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/dialplan/public.xml
  144. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/directory/default.xml
  145. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/directory/default/*.xml
  146. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/sip_profiles/*.xml
  147. %config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/sip_profiles/external/*.xml
  148. ### END OF config-rayo
  149. ######################################################################################################################
  150. #
  151. # Changelog
  152. #
  153. ######################################################################################################################
  154. %changelog
  155. * Tue Jun 10 2014 crienzo@grasshopper.com
  156. - Remove dependency to high resolution music and sounds files
  157. - Remove dependency to specific FreeSWITCH package version
  158. * Mon Jun 03 2013 - crienzo@grasshopper.com
  159. - Added users and internal profile for softphone testing
  160. * Wed May 08 2013 - crienzo@grasshopper.com
  161. - Initial revision