2
0

st.spec 2.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. Summary: State Threads Library
  2. Name: st
  3. Version: 1.9
  4. Release: 1
  5. Copyright: MPL 1.2 or GPL 2+
  6. Packager: Wesley W. Terpstra <wesley@terpstra.ca>
  7. Source: http://prdownloads.sourceforge.net/state-threads/st-%{version}.tar.gz
  8. Prefix: /usr
  9. BuildRoot: /tmp/%{name}-%{version}-build
  10. Group: Development/Libraries
  11. %description
  12. The State Threads library has an interface similar to POSIX threads.
  13. However, the threads are actually all run in-process. This type of
  14. threading allows for controlled schedualing points. It is highly useful
  15. for designing robust and extremely scalable internet applications since
  16. there is no resource contention and locking is generally unnecessary.
  17. It can be combined with traditional threading or multiple process
  18. parallelism to take advantage of multiple processors.
  19. See: <http://state-threads.sourceforge.net/docs/st.html> for further
  20. information about how state threads improve performance.
  21. %package -n libst-devel
  22. Summary: State Threads Library - Development Files
  23. Group: Development/Libraries
  24. Requires: libst1
  25. %description -n libst-devel
  26. Development headers and documentation for libst
  27. %package -n libst1
  28. Summary: State Threads Library - Shared Libs Major 1
  29. Group: System/Libraries
  30. %description -n libst1
  31. Shared libraries for running applications linked against api version 1.
  32. %prep
  33. %setup -q
  34. %build
  35. make CONFIG_GUESS_PATH=/usr/share/automake default-optimized
  36. %install
  37. if [ -d ${RPM_BUILD_ROOT} ]; then rm -rf ${RPM_BUILD_ROOT}; fi
  38. mkdir -m 0755 -p ${RPM_BUILD_ROOT}/%{prefix}/lib/pkgconfig
  39. mkdir -m 0755 -p ${RPM_BUILD_ROOT}/%{prefix}/include
  40. mkdir -m 0755 -p ${RPM_BUILD_ROOT}/%{prefix}/share/doc/libst-devel
  41. cp -a obj/libst.* ${RPM_BUILD_ROOT}/%{prefix}/lib
  42. cp -a obj/st.h ${RPM_BUILD_ROOT}/%{prefix}/include
  43. sed "s*@prefix@*%{prefix}*g" <st.pc >${RPM_BUILD_ROOT}/%{prefix}/lib/pkgconfig/st.pc
  44. cp -a docs/* ${RPM_BUILD_ROOT}/%{prefix}/share/doc/libst-devel/
  45. cp -a examples ${RPM_BUILD_ROOT}/%{prefix}/share/doc/libst-devel/
  46. %post -n libst1
  47. /sbin/ldconfig %{prefix}/lib
  48. %files -n libst1
  49. %defattr(-,root,root)
  50. %{prefix}/lib/lib*.so.*
  51. %files -n libst-devel
  52. %defattr(-,root,root)
  53. %{prefix}/include/*
  54. %{prefix}/lib/lib*.a
  55. %{prefix}/lib/lib*.so
  56. %{prefix}/lib/pkgconfig/st.pc
  57. %{prefix}/share/doc/libst-devel/*
  58. %clean
  59. if [ -d ${RPM_BUILD_ROOT} ]; then rm -rf ${RPM_BUILD_ROOT}; fi
  60. %changelog
  61. * Wed Dec 26 2001 Wesley W. Terpstra <wesley@terpstra.ca>
  62. - first rpms for libst-1.3.tar.gz