apr.spec 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596
  1. %define aprver 1
  2. Summary: Apache Portable Runtime library
  3. Name: apr
  4. Version: 1.2.8
  5. Release: 1
  6. License: Apache Software License
  7. Group: System Environment/Libraries
  8. URL: http://apr.apache.org/
  9. Source0: %{name}-%{version}.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  11. BuildPrereq: autoconf, libtool, doxygen
  12. %description
  13. The mission of the Apache Portable Runtime (APR) is to provide a
  14. free library of C data structures and routines, forming a system
  15. portability layer to as many operating systems as possible,
  16. including Unices, MS Win32, BeOS and OS/2.
  17. %package devel
  18. Group: Development/Libraries
  19. Summary: APR library development kit
  20. Requires: apr = %{version}
  21. %description devel
  22. This package provides the support files which can be used to
  23. build applications using the APR library. The mission of the
  24. Apache Portable Runtime (APR) is to provide a free library of
  25. C data structures and routines.
  26. %prep
  27. %setup -q
  28. %build
  29. # regenerate configure script etc.
  30. ./buildconf
  31. %configure \
  32. --prefix=/usr \
  33. --includedir=%{_includedir}/apr-%{aprver} \
  34. --with-installbuilddir=%{_libdir}/apr/build-%{aprver} \
  35. --with-devrandom=/dev/urandom \
  36. CC=gcc CXX=g++
  37. make %{?_smp_mflags} && make dox
  38. %check
  39. # Run non-interactive tests
  40. pushd test
  41. make %{?_smp_mflags} testall CFLAGS=-fno-strict-aliasing
  42. ./testall -v || exit 1
  43. popd
  44. %install
  45. rm -rf $RPM_BUILD_ROOT
  46. make install DESTDIR=$RPM_BUILD_ROOT
  47. # Move docs to more convenient location
  48. mv docs/dox/html html
  49. # Unpackaged files:
  50. rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
  51. %clean
  52. rm -rf $RPM_BUILD_ROOT
  53. %post -p /sbin/ldconfig
  54. %postun -p /sbin/ldconfig
  55. %files
  56. %defattr(-,root,root,-)
  57. %doc CHANGES LICENSE NOTICE
  58. %{_libdir}/libapr-%{aprver}.so.*
  59. %files devel
  60. %defattr(-,root,root,-)
  61. %doc docs/APRDesign.html docs/canonical_filenames.html
  62. %doc docs/incomplete_types docs/non_apr_programs
  63. %doc --parents html
  64. %{_bindir}/apr*config
  65. %{_libdir}/libapr-%{aprver}.*a
  66. %{_libdir}/libapr-%{aprver}.so
  67. %dir %{_libdir}/apr
  68. %dir %{_libdir}/apr/build-%{aprver}
  69. %{_libdir}/apr/build-%{aprver}/*
  70. %{_libdir}/pkgconfig/apr-%{aprver}.pc
  71. %dir %{_includedir}/apr-%{aprver}
  72. %{_includedir}/apr-%{aprver}/*.h
  73. %changelog
  74. * Tue Jun 22 2004 Graham Leggett <minfrin@sharp.fm> 1.0.0-1
  75. - update to support v1.0.0 of APR
  76. * Tue Jun 22 2004 Graham Leggett <minfrin@sharp.fm> 1.0.0-1
  77. - derived from Fedora Core apr.spec