rules 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. #!/usr/bin/make -f
  2. # This debian/rules file is provided as a template for normal perl
  3. # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
  4. # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
  5. # be used freely wherever it is useful.
  6. # Uncomment this to turn on verbose mode.
  7. #export DH_VERBOSE=1
  8. # If set to a true value then MakeMaker's prompt function will
  9. # always return the default without waiting for user input.
  10. export PERL_MM_USE_DEFAULT=1
  11. PERL ?= /usr/bin/perl
  12. PACKAGE = $(shell dh_listpackages)
  13. TMP = $(CURDIR)/debian/$(PACKAGE)
  14. build: build-stamp
  15. build-stamp: $(QUILT_STAMPFN)
  16. dh_testdir
  17. $(PERL) Makefile.PL INSTALLDIRS=vendor
  18. $(MAKE)
  19. PERL_TEST_POD=1 $(MAKE) test
  20. touch $@
  21. clean:
  22. dh_testdir
  23. dh_testroot
  24. dh_clean build-stamp install-stamp
  25. [ ! -f Makefile ] || $(MAKE) realclean
  26. install: install-stamp
  27. install-stamp: build-stamp
  28. dh_testdir
  29. dh_testroot
  30. dh_clean -k
  31. $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
  32. # lintian override for a long line with a hash
  33. # dh_installdirs /usr/share/lintian/overrides/
  34. #install -m 644 $(CURDIR)/debian/lintian-overrides $(TMP)/usr/share/lintian/overrides/$(PACKAGE)
  35. #[ ! -d $(TMP)/usr/lib/perl5 ] || \
  36. # rmdir --ignore-fail-on-non-empty --parents --verbose \
  37. # $(TMP)/usr/lib/perl5
  38. touch $@
  39. binary-arch:
  40. # We have nothing to do here for an architecture-independent package
  41. binary-indep: build install
  42. dh_testdir
  43. dh_testroot
  44. dh_installdocs README
  45. dh_installchangelogs ChangeLog
  46. dh_perl
  47. dh_compress
  48. dh_fixperms
  49. dh_installdeb
  50. dh_gencontrol
  51. dh_md5sums
  52. dh_builddeb
  53. binary: binary-indep binary-arch
  54. .PHONY: build clean binary-indep binary-arch binary install